Jump to content
wanderer

urgent help with electrics wanted

Recommended Posts

Hi all been to a show in Preston this morning car started as usual on way i turned my fan on which is switch operated and rh indicator stayed on, on arrival turned and took out key engine carried on running until i switched fan off tried to start it but no joy until i turned fan on which then primed the fuel pump drove home with indicator stuck on and electronic speedo all over the place,removed the dash but cant see anything wrong any ideas thanks

Share this post


Link to post
Share on other sites

I have a similar problem that i am too lazy to fix. if i put my hazards on then turn off the ignition engine still runs , i think you have managed to wire the non ignition  side of the electrics to the ignition on side  of the electrics. in my case its 2 wires on the hazard switch. I would check your feed for your fan and also where you have earthed your fan .

Being a cobbler you are the worst shod guy in the street ....... I'm an electronics engineer.🙄

Hey ho 

Best wishes

Derek

Share this post


Link to post
Share on other sites
3 hours ago, mr D said:

Being a cobbler you are the worst shod guy in the street ....... I'm an electronics engineer.🙄

😀 I know what you mean - I did electrical and electronic engineering at uni years ago and electrics still confuse me. I fitted a new USB  socket recently and ever since then, my voltmeter gauge has been under-reading. Then, today, I plugged my mobile phone in to the USB and the voltmeter suddenly reads correctly! 😜

Share this post


Link to post
Share on other sites
On ‎4‎/‎21‎/‎2019 at 8:43 PM, nelmo said:

😀 I know what you mean - I did electrical and electronic engineering at uni years ago and electrics still confuse me. I fitted a new USB  socket recently and ever since then, my voltmeter gauge has been under-reading. Then, today, I plugged my mobile phone in to the USB and the voltmeter suddenly reads correctly! 😜

Some switched-mode power supplies (which is nearly everything now) need a load on them to work properly. 

Edited by bullfist
incorrect info

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...