Jump to content
Del1968

Run on

Recommended Posts

What are the causes of run on when engine switched off and hard starting when hot any ideas 

Share this post


Link to post
Share on other sites

Sounds like the timing is too far advanced 

Andi 

Share this post


Link to post
Share on other sites

Its only really started doing it today when I put it back in the garage after a hard run it is booked in next sat for rolling rd and tune up to me it’s never run right since it had the fast rd cam put on and the injection head I don’t think it was ever really set up properly that was 2 yrs ago and sat in the garage for 2 yrs so not really took it out for a good run until I got mot done 

Share this post


Link to post
Share on other sites

It does sound like timing. Presumably it's fitted with a distributor? If it is then check the clamp hasn't worked loose. Other than that if it still starts and runs well enough to get to the rolling road then I wouldn't touch it. All will become apparent as soon as it's on the rollers and connected up, they will sort out any problems far faster than any mere mortal working out of their own garage. Mine found another 25 horsepower just by bending the stops on the advance retard mechanism!  It will be money well spent as they can check so many different parameters against each other while the engine is performing as it would on the road. Can't do that at home.

Share this post


Link to post
Share on other sites

Yer got an electronic ignition distributor so I will just let the rollers sort it out thanks for the help 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...