Jump to content
Sign in to follow this  
Del1968

Performance drop

Recommended Posts

Hi all a little story about my car I brought my exmo 3 yrs ago had it for a year but hardly drove it at the time I brought it the head was standard with a Kent fr30 cam on it and it drove lovely at the end of 2016 I had the head swapped for an injection head with a Kent fr32 cam put on its a pinto 2.1 now the car has stood in the garage for 2yrs turning over every so often this yr I got it mot’d and all the rest got it rolling rd tuned and to came back at 96 at the flywheel can’t remember what it was at the wheels anyway I checked the old print out of when it was last dyno tested and for some reason it was loads better with the old head on any ideas

cheers Del 

Share this post


Link to post
Share on other sites

what carbs are you using?  it doesnt sound like it is a million miles away from where it should be with an FR32 cam and assuming a standard injection head.

What did it make on the old head and cam?

How does it feel to drive compared to the old setup?

Share this post


Link to post
Share on other sites

It’s got a Weber 32/36 carb I try and get a pic up of both dyno tests 

running wise it seems to get hot now and runs bit lumpy but was told that’s the cam the fr32 runs that way driving it don’t seem as smooth as it was with old set up was told to get a 38 dgas put on which would give it a bit more 

starting seems a problem now takes a while to start when cold and hot 

Share this post


Link to post
Share on other sites

38dgas would be overkill on that setup imo.  A well setup 32/36 should be fine.  FR32 is a very mild cam, shouldnt be a massive difference to the Fr30 you had in, slightly different power band but thats about it.

I'm thinking ignition timing is the issue. Have you got a timing light?  Worth checking what the timing at idle with the vacuum pipe removed from the dizzy is.  Should be 8-10 degrees.

Share this post


Link to post
Share on other sites

I have got a timing light but ain’t got a clue how to use it the old saying “all the gear no idea” and got electronic distributer 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...