Jump to content

Search the Community

Showing results for tags 'oilcapacity'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Committee Matters
  • RHOCaR - Information and Events
    • News
    • Events
    • Club Information
  • Construction
    • Chassis
    • Donor
    • Fitting & bodywork
    • Engine
    • Mechanics
    • Electrics
    • IVA
  • Adverts
    • For sale
    • Wanted
    • Other classifieds
  • Members Lounge (Access is via RHOCaR membership only)
    • Member Discounts
    • Loan shark
    • Build Threads
    • Build Blog Links
  • On the road issues
    • Maintenance & Modifications
    • Driving
  • General
    • Kit car related
    • Chit chat
    • Test area
  • Moderators

Product Groups

  • Treasure Hunt
  • Huntingdon BBQ Weekender
  • Club Merchandise
  • Track Days
  • End of Season Bash 2022

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Car type


Full name

Found 1 result

  1. Hi Guys Yes it's me again, the annoying bloke with lots of questions! I Picked my car up last week and before I drove it home I checked the oil level. Bang on maximum. However at low revs the oil light would flicker. I put this down to the oil being stood for 3 years while car was not being used. Today I decided to change the oil and filter. A quick google revealed the 2.0 Pinto engine should have around 3.8 litres of oil inc filter? firstly is this correct? secondly I drained about 2.6 litres out the engine. I have now put in 3.8 litres but the level is about twice as far as the maximum line on the dipstick. So my assumption is the car may have the wrong dipstick? I have attached photos of the dipstick and sump in case anyone can offer me some advice. Thanks in advance Ray
×
×
  • Create New...