Jump to content
The Stig

Cortina Gauges, Sierra Senders!

Recommended Posts

Hi there just wandering if anyone can shed any light on this one for me, as im now unsure!

 

My S7 is fitted with the origional Cortina Mk4/5 instrument binicle, i am having trouble getting the Temp and fuel gauges to give any reading.

I know that they work cos when i ground the fuel sender wire and temp sender wire the gauges move accross the full scale.

 

I have fitted a new fuel sender from Kit Parts Direct, and changed the temp sender from a working sierra but still no readings :huh:

 

Did the Cortina use senders with differing resistance readings? i would of guessed that they would be the sane as sierra?

 

Any ideas welcome please ;)

Share this post


Link to post
Share on other sites

hi,make sure you dont use ptfe tape on the oil and temp senders because it will insulate the earth and get no reading.hth.

jess.

Share this post


Link to post
Share on other sites

Hi,

If they're Cortina Gauges then you be needing Cortina senders.

Uncle Henry (in his wisdom) very rarely kept to standards such as this.

I doubt there's very little from the Cortina that ever made it onto the Sierra.

Share this post


Link to post
Share on other sites
hi,make sure you dont use ptfe tape on the oil and temp senders because it will insulate the earth and get no reading.hth.

jess.

Hi there, no thers no ptfe tape, senders are on tapered thread so seal all ok.

Share this post


Link to post
Share on other sites
Hi,

If they're Cortina Gauges then you be needing Cortina senders.

Uncle Henry (in his wisdom) very rarely kept to standards such as this.

I doubt there's very little from the Cortina that ever made it onto the Sierra.

I guess that ure probably right, has anybody any ideas for cortina senders?

Share this post


Link to post
Share on other sites

This is a common problem with the Cortina instrument binicle.

On my S7 the temp gauges is very tempermental, it can go for months without working then for no reason at all it will work

again just fine for months. :crazy: Same thing with the binicle on the Eagle RV too temp gauge dont work at all. :unknw:

Tried different sender but still the same problem.

Fuel gauge on both work ok :o :rolleyes:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...