Jump to content

Search the Community

Showing results for tags 'electrics'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Committee Matters
  • RHOCaR - Information and Events
    • News
    • Events
    • Club Information
  • Construction
    • Chassis
    • Donor
    • Fitting & bodywork
    • Engine
    • Mechanics
    • Electrics
    • IVA
  • Adverts
    • For sale
    • Wanted
    • Other classifieds
  • Members Lounge (Access is via RHOCaR membership only)
    • Member Discounts
    • Loan shark
    • Build Threads
    • Build Blog Links
  • On the road issues
    • Maintenance & Modifications
    • Driving
  • General
    • Kit car related
    • Chit chat
    • Test area
  • Moderators

Calendars

  • Club Calendar

Product Groups

  • End of Season Bash 2020
  • Treasure Hunt
  • Huntingdon BBQ Weekender
  • Club Merchandise
  • Track Days

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


E-mail


Location


Interests


Car type


Full name

Found 5 results

  1. Tazza67

    Exmo Re-Wire

    Ok so carried over from one of the other threads that I kind of hijacked.... thanks to Nigel for all the help so far! I've decided that I want to redo the electrics on the EXMO partly as the old sierra loom has definitely seen better days (soldered joints are failing apart) but largely to expand on my knowledge... there's a serious lack when it comes to electrical stuff - I can't see it working so struggle more than mechanical stuff. Point to note: my kit car is stored at the parents house in Cornwall while I am away working in the Midlands so alot of this is having to be done with some ph
  2. just found this wont be needing it for mine (got mini/Landrover one £15 + postage or collect from ba5 3au area postage will be £7
  3. Hi all, sorry again Mr dictator, could do with a bit of help on my electrics, modified my dashboard a bit, but I think I've got to my limits regarding the wiring. Somehow I've lost my indicators, hazards and brake lights, So I was wondering if there were any auto electricians around the south Yorkshire area, will need a good sense of humour to understand my handy work,would really appreciate the help, Cheers Ivan
  4. I'm hoping one of you genuis's out there can help a novice... Indicators work OK but my hazards don't! I've checked the fuses (all OK) and I've replaced the switch and relay but still no joy? If I disconnect the hazard switch the indicators don't work, if I flick the hazard switch on then the indicators also don't work! If the hazard switch is connected but not turned on then the indicators then work again... I don't know very much about car electrics, well actually I know nothing, but I've done the basics and come up with a blank. Please tell me I'm being stupid, or more help
  5. Hi guys, I have several quieries I hope someone can answer. I'm in the final throws of completing my Zero and trying to tie up a lot of loose ends. (1) My HP Fuel pump has two connections, a thin pillar and a larger one. On my 'plug and go' engine loom I have two wires to go to the pump, a blue wire and a brown wire. Which one goes to which? (2) I have an Induction Sensor EMP34 - 1Kit for the speedometer. Does it require magnets or is it impulsed from the diff flange nuts? (3) On my engine loom for the Zetec engine I have two redundant plugs : One is for 'Air temperature'
×
×
  • Create New...