Jump to content

Search the Community

Showing results for tags 'Engine'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Committee Matters
  • RHOCaR - Information and Events
    • News
    • Events
    • Club Information
  • Construction
    • Chassis
    • Donor
    • Fitting & bodywork
    • Engine
    • Mechanics
    • Electrics
    • IVA
  • Adverts
    • For sale
    • Wanted
    • Other classifieds
  • Members Lounge (Access is via RHOCaR membership only)
    • Member Discounts
    • Loan shark
    • Build Threads
    • Build Blog Links
  • On the road issues
    • Maintenance & Modifications
    • Driving
  • General
    • Kit car related
    • Chit chat
    • Test area
  • Moderators

Product Groups

  • End of Season Bash 2020
  • Treasure Hunt
  • Huntingdon BBQ Weekender
  • Club Merchandise
  • Track Days

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


E-mail


Location


Interests


Car type


Full name

Found 13 results

  1. Hi i have a rover 2.0 t series super spec which starts and runs on tick over but give it the slightest bit of throttle and it cuts out ,. ive been in-touch with with Alan richey who has made a study of the ecu and he told me it sounded like the TPS , i checked this out and he seems to have put his finger on the problem because with or without it plugged up its just the same i need to discover if its the wiring or the sensor does anyone know how to test the sensor before i go shelling out my had earnt , thanks Dave
  2. After months of not being able to start the engine, despite fuel, spark, air and timing all OK (Pinto 2.0 with DGAV Webers), it started yesterday by holding a rag over the air intake to the carb. Battery has died due to the number of times I have tried to start the car. Today with a new battery, same thing. Car won't start, but as soon as I put a rag over the air intake it started fine. Once it has been running for a few in minutes it then starts fine every time, while it is hot. Any ideas why or what to do? Thanks
  3. I have a pinto engine with twin webers. It runs quite well under light acceleration but after heavy acceleration the engine and exhaust start to feel like they are being choked. This get steadily worse until the engine loses all power and needs to be left for an hour to recover. Could anyone suggest what might be causing this please? Would air leaks in th exhaust cause this?
  4. Hi, could anyone help me with info on the best place to get engine mounts for a Zetec black top in a good 2b? I've seen some on eBay for £50 odd, are these any good, are they a good fit? Or are they universal? Thanks in advance for any help
  5. Hi all I've Decided to go for the c20xe option into the 2b, also been offered a '92 Sierra 1.8lx manual. Would it be worth buying the whole car rather than sourcing a gearbox? What bits are needed from a Sierra to get the xe into my hood 2b I already have a Sierra rear diff and prop. Thanks in advance for any help
  6. Hi I've recently purchased a 2b, Asking for info on the best/easiest engine instal option? The car currently has rear diff and prop to run a 2 litre pinto set up, the engine and gearbox is no longer with the car. My rough thoughts are leaning towards either the 2.0 Zetec or the st170 engine, or possible a vauxhall red top?I know I'm asking for a lot of info but could anyone advise me of options and parts I'll need ie any conversion kits available to get the Zetec in the 2b?, gearbox options? Can I run the standard injection and ecu? Or do I have to switch to bike carbs/throttle bodies, thank
  7. GBS Zero – For Sale List After recent hard financial worries the car is going to have to be sold and unfortunately the best money following Femsters sale seems to be in pieces, which is a real shame but here goes. I am based in Huddersfield, West Yorkshire M1 J38, M62 J24/25, but will be in Warwick on 20/21 October and London the Tuesday before so can meet up, but funds must be cleared through Paypal before I load. Please PM if you want any parts, they will be taken off the list as funds are recieved, the rest will go on Ebay in 10 days time, first offer to the guys on here. I will
  8. matvic

    Replacing Engine

    I have broken my engine (block or piston) and am using it as an excuse to change from a 1.6 pinto to a 2.0. Apart from the engine what else will I have to change to cope with the 2.0?
  9. Hi all, i am urgently after a running good 2.0l pinto engine if anyone can assist please pm me details. regards keith
  10. Mr_Frosty

    Dead Engine?

    So here it is. Nice day so I changed my oil for Valvolene 20w-50 on my 2.0 pinto engine. Take her for a drive to put some fuel in her after having very little in over winter. On my way back home so engine is warm nice long straight so give it some loud pedal get to lets say a swift speed holds it for a little them something goes pop? Oil pressure is down from being at 55ish psi to 20psi and water temp rises and LOTS of blue smoke. Got it home not very far like 1 mile driving slow turned her off. Now when I turn it on it still runs on all four cylinders but now making a clattering n
  11. Hi chaps, Can I change the Zetec sump to a Raceline with the engine in the chassis? Hopefully this will be a simple question to answer. I need to know if I should order the raceline sump at this point in the build if I don't have to. The reason being is that my paycheck won't stretch that far for my Easter break when I'm taking a week off work...and want lots to do. Has anyone gone down this path? Every build I've seen seems to do it off the car. Cheers Chris
  12. Hi All, I wanted to source some opinion first before I go any further. I have managed to get hold of a whole 1992 sierra sapphire which I am currently in the process of slowly dismantling. I have only had about 2 full days and a number of cold evenings to look at it so I've just been taking doors and accessories apart. Anyway, when I got the car, it started fine and I managed to drive it onto the drive without any issue. Come about a month later, I cannot get the bloody thing to start (it's the 2.0l DOHC if anybody is interested). I am pretty much certain that the problem is on
×
×
  • Create New...