Jump to content
Sign in to follow this  
Scotty84

A Few Niggles.....

Recommended Posts

Hey all, I have a few nigggles with the electric side of my RH7. I am not Electrically minded when it comes to cars so just need a push in the right direction.

 

1. Headlights....

From what I can see I have side light and a main beam bulb in each headlamp. I have the sierra column with stalks and get the following functions with each.

Light switch up 1 turns only sidelights on, up 2 times turns only sidelights on, but if I push the main beam stalk (indicator) the main bulb will come on.

 

Is that the right set up? So there is only side light and dipped/main beam or am I meant to have side, dipped, main like normal?

 

2. Hazard switch....

With my recent breakdown I had to use my hazard switch, my issue is I have had to disconnect it to turn it off. I just cant get them to click off by pressing down the switch on the column. Am I best buying a push button switch on the dash for this?

 

3. Stereo.....

I need music lol. Is it as easy as I think it is and just a case of installing headunit and getting power to it then wiring in some speakers?

 

I am pround of myself though and today repaired the brake light switch, Ok simple job but found the fault and fixed it. Basically my brake lights were always on, just had to move the switch forward so the peadal in rest position was touching it.

 

Cheers peeps ;)

Share this post


Link to post
Share on other sites

Light switch possition 1 all off.

2 sidelights only.

3 side and dip.

Indicator stalk fully towards you flash headlamps main beam.

At rest dip beam.

One more click away from you main beam, or main and dip together, dependant on loom.

Headlamps power up through relays for dip and main.

I am like you with wiring so can't go further than that.

If Longboarder reads your post I'm sure he will help with required explanations and diagrams. Great bloke.

  • Like 1

Share this post


Link to post
Share on other sites

Cheers 2b,

Going by that I havent got dipped beam then as set 2 is side light only and 3 sidelights only. I only get main beam when stalk pushed forward, no dipp when rest.

 

Will have a poke around at the relays tomorrow with a volt meter see whats going on.

I am guessing the sigle bulb in the headlamp is both a dipped and main then.

Share this post


Link to post
Share on other sites

Correct.

Start with fuses then bulbs then relays.

After that spaghetti magic stuff.

Share this post


Link to post
Share on other sites

Lighting is exactly as described. The right hand column switch is just an on /off switch. The left column stalk serves out the electric either to the main beam or the dipped beam. Most people have fitted twin filiament bulbs in the headlamps, probably H4. They have three terminals wired to main relay, dip relay and a common earth. There will also be a little 5 or 10 watt sidelight bulb in there separately with a supply and earth. The earths tend to get joined so only four wires come out of the headlamp 'pod'.

If you get main beam with the left stalk in the fully forward rest position (toward the engine!) that's great. It means the right column stalk is doing all it should and can be ignored. If so then your fault finding can just be the dip relay supply, dip relay switching, the relay itself, wires from dip relay to headlamp. (Headlamp earth will be OK cos the main beam uses it and works.)

You may also get main beam with the stalk pulled fully toward your chest (for flash) but the stalk won't stay in this position and clicks back to the middle position which should be dip.

 

Hazard switch often responds to a squirt of switch cleaner or WD40 and repeated pressing on/off to free it up.

 

You can fit a radio and speakers but you won't hear much over 50 mph and it all may get wet. It will certainly get damp ++.

 

Nigel

Share this post


Link to post
Share on other sites

Check bulbs are correct and give continuity first thing.

Not that uncommon to blow two bulbs at the same time.

Or some divit forced the wrong bulbs in.

Edited by 2b cruising

Share this post


Link to post
Share on other sites

I wouldn't hear a radio above the noise of my exhaust!!!

Share this post


Link to post
Share on other sites

Cheers guys, yes going to look into a headunit that we can plug headsets into and Have 2 6x9's behind each seat.

 

Had a tinker today and its Dipped beam thats working not the main, So The lights dont flash when the stalk is pushed towards you and dipped beam goes off if stalk is pushed back but no main beam comes on..... Whats the chances the bulb is just a H4 dipped beam? There is a blue tint to it so last owner may have put a xenon looking bulb in place.....

 

Going to buy some new bulbs tomorrow and go from there.

 

Also something I never noticed till today..... I have no reverse light. Is this an MOT failure? Will it be easy enough to install one?

 

Cheers all

Share this post


Link to post
Share on other sites

my reaction is either a fuse for main beam or the dip switch needs spraying with switch cleaner (obtain from maplins)

Share this post


Link to post
Share on other sites

If the bulbs only have two pins, they are wrong.

I stand by my earlier observation about fuses and relays though.

As Nigel said though, the dip beam uses the same supply at the stalk switch for main and dip.

This then points to, switch contacts, doubtful as both positions for main not working.

Switch feed wire to main beam relay no continuity.

Relay itself faulty

Power wire from relay to headlamp.

As mentioned already busted bulbs. You have two filaments inside the correct bulbs, two feed each filament separately. The earth is picked up by the outer metal case of the bulb through the bulb holder body.

Hold ohms tester on one contact and the bulb body. Should be no or very little resistance.

If ok, test the other contact in the same way. If all ak.

Turn on the main beam and check for power through the bulb holder. If no power go to the relevant relay and check for power from both on the small supply wire and the main feed wire. If ok check for power coming out of the relay.

The smal power wire will only work with ignition and main on. The main supply wire will be live all the time.

The relay to bulb wire should only be live with ignition and main switched on.

Sadly I cannot advise as to which relay does what. They are not usually listed in the ford fuse lid, but the fuses are. The relays are letter identified next to their holders.

Edited by 2b cruising

Share this post


Link to post
Share on other sites

Scotty, what about the dash buld for the indicators, flashes on left turn, but doesn't flash on the right turn (or the other way round).

Si

  • Like 1

Share this post


Link to post
Share on other sites

Scotty, what about the dash buld for the indicators, flashes on left turn, but doesn't flash on the right turn (or the other way round).

Si

Haha yes forgot about that

 

Think I found the fault anyway.....

 

 

 

 

Robin hood build plaque number is 0666 😥

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...