Jump to content


Recommended Posts

Hello All,


It's been a long time since I've been on here, but I have an electrical issue which one of you out there may be able to help me with;

The other day, my car refused to start - Turned the key - Fired, but then nothing - No sparks at all. Humph!

I have an Aldon Ignitor unit fitted in place of the Points & Condensor, which has given me many years of trouble free motoring. Fit & forget, they said.

I did various checks after scouring the 'tinterweb, to no avail. Checked circuits for continuity, swapped out the coil - still no sparks.

I have a very simple setup: Pinto 2 Litre, 3 ohm Coil (No Ballast) and a Bosch Distributor with the (expensive!) Aldon Ignitor inside.

It was suggested/recommended on the 'tinterweb that I disconnect the Tacho (Capri Clocks) from the Neg side of the Coil, whilst doing various checks, so I did.Checks continued and everything pointed to the Aldon Ignitor. I'd checked all the wiring and swapped the coil, so really it couldn't be anything else. So, bit the bullet, new Powerspark Ignitor on order.

So for now I'm temporarily running on Points & Condensor (Thanks Bob). Engine now running - All OK.

Here's the issue.

Stopped the engine to re-connect the Tacho lead back onto the Neg side of the Coil. Turned the key, but engine refused to fire.

Disconnected the Tacho lead from the Neg side of the coil. Turned the key and engine fired up.

Question is; What's going on here? Is there any chance that a fault in the Tacho has fried the Aldon Ignitor, or vice versa?

Does anyone have any experience of a situation like this happening to them?

My concern is that I don't want to fit the new Ignitor unit when it arrives and toast it straight away, without getting to the bottom of this Tacho issue.

I do have another Tacho somewhere - maybe I could try that?


Many Thanks & Regards...

Edited by Grizzly

Share this post

Link to post
Share on other sites

The joys of old tech. Coils have a 'ignition on' positive supply and are fired by the points switching the negative. I'm guessing your tacho is the problem or its connecting wire to the coil negative having gone to a constant earth/ground. Quick check is to disconnect it again from the coil and test it. Should be open circuit. If it's an earth the wire may have shorted to earth or the tacho failed.

Long time no see!

Share this post

Link to post
Share on other sites

Cheers Nigel,

I mightve guessed youd be quick to chip in! 👍

Thanks, Ill do some checks tomorrow and report back.

Yes, I went walkabouts for a while, but back in the fold now. Hope youre keeping well Sir?

Thanks again...

Share this post

Link to post
Share on other sites



OK. Tacho wire from Neg side of the Coil goes straight to earth. :(


I'll need to trace this wire back to the Tacho and also, get the Instrument Cluster out and test the Tacho itself.

I have a spare Tacho, which measures an open circuit, but I don't want to do a straight swap until I've checked this all through.


Quandry is; Did the Tacho possibly get fried by the Ignitor, or did the Tacho possibly fry the Ignitor?

Either way, and going forwards, would a fuse offer any protection?

Haynes Manual (Sierra) does refer to a Suppressor, but I may be looking at the wrong diagram?


Many Thanks...

Edited by Grizzly

Share this post

Link to post
Share on other sites

I am guessing that the wire from the coil to the tacho has worn through its insulation at some point.

Try disconnecting from the back of the tacho and again check for shorts, problem with this is often disconnecting a wire moves loom and hides the short so try to move as little as possible when checking.

Share this post

Link to post
Share on other sites

Understood and thanks Ian. I will progress this as soon as possible, but it won't be until next week now.

Powerspark Ignitor turned up today, but as said, I won't be fitting it until the Tacho issue is resolved.


Interestingly, on the back of the packaging, one of the Fitting Instructions states;

‘Then connect the Powerspark BLACK to the (-‘ve or 1) ensuring no other wire is on that same side”
I asked them how I should re-connect the Tacho?


They replied;

Try connecting the tacho to the Positive (+'ve) terminal on the coil.
Connecting it to the Negative terminal, will Earth out the coil/kit and prevent the kit from working.

Anyone else done it this way?

Strange because the Aldon Ignitor was happy with the Tacho feed coming from the -'ve for many years.

I assume that this would be ok being fed from the +'ve, but I'm getting paranoid now. :sorry:

Share this post

Link to post
Share on other sites



Connecting it to the Negative terminal, will Earth out the coil/kit and prevent the kit from working.

Going back to basics the tacho 'reads' the off/on/off/on of the coil switching. It has to read the side of the coil that is being switched. For the last 40 years it's the negative wire that is almost universally switched. Over the last few years of cars becoming electronic rather than electrical lots has changed but coils are pretty much the same with just the two wires and they have always worked better if the negative is switched. Yours was fine for years with the tacho reading the negative switching of the Aldon.

Wether the wire went to constant earth, the tacho or the Aldon spat the dummy or what fried what, I haven't a clue. The tacho wire didn't used to go to earth because if it had constant live on one pole and constant earth on the other there would be no switching and no spark.

So you are safe to fit the Aldon and drive tacho-less.

Fault find the tacho wire. Carefully pull the plug from the instruments. Does the tacho wire go the earth. Plug back in. Does the tacho wire go to earth. Repeat several times to see if the result is repeatable (to try to get around the problem of disturbing the loom breaks the short circuit.) You should end up with a reasonable idea that it's the wire that's earthing or the tacho that's fried and gone to earth. Then sort it and get a tacho back on the negative of the coil as you always had it.

You might have spoken to the tea boy at Aldon.

Supressor might help radio reception. Fuse won't help anything.

Edited by Longboarder

Share this post

Link to post
Share on other sites

Hello All,

Time for an update!

Managed to do some more investigations last week, but was unable to find any short circuits. Removed instrument cluster and Tacho was closed circuit - ie no longer going to earth and wire to it from the coil seemed good too. Anyway, removed a bit of redundant wiring and had a general tidy up under the dash. All seemed to be OK and no obvious faults found. Put everything back together, started the car and reconnected the Tacho. Everything working as before, albeit on Points & Condensor. Hmmmm....

Did a few shortish trips and all seemed well. About 30 miles in total.

Went out on Monday for a slightly longer run. My wife was following, as we had an appointment and then both needed to go to separate other places.

Good job. Managed about 10 miles and then broke down - zero sparks. Had to abandon the car (secure location) until I had time to look into it further.

Went back to it the next morning. Fitted a brand new set of Points & Condensor and it fired up! Ran a bit rough - it'd been out in the rain all night, but I got it home ok.

Finally got around to having another look at it this morning, but she refused to start - no sparks????? This last Points & Condensor set was brand new and only done 10 miles!

Did some more checks, but was getting quite perplexed now....

Fitted the new Powerspark Ignitor Unit and she fired up! Tacho working (from -'ve side of coil) too!

Took the Powerspark Ignitor Unit off and put the Points & Condensor back on - Zilch.

Refitted Powerspark Ignitor Unit and went out for a run, did 20 miles or more and running sweet.

So,,,, this car seems to be quite happy with Electronic Ignition, but appears to be very intolerant to Points & Condensor operation. The trouble is, I cannot fathom why?

As I said before. I have a very simple set-up. I bought this kit very part started. There's no ECU or AMP (sorry, I don't know if they're the same thing?). Maybe that's the problem?

I've ordered some new Plugs, HT Leads, Distributor Cap, Rotor Arm, and a new 3 Ohm Coil. The Distributor was new a few years ago. Apart from the wiring, there's nothing else.

During my investigations though, I did notice some lightweight (non cranking power) wires at the solenoid on two terminals. Not quite sure what all these are though. My concern is that this vehicle has not been wired 100% correct from day one and maybe runs OK with electronic Ignition, but isn't happy with Points & Condensor.

But, at least we're back on the road. Not confidant going forward though, that everything is good? :sorry:

Edited by Grizzly

Share this post

Link to post
Share on other sites

Hmm. Killed two sets of points. Might be coil is wrong for points? Points heel wear? Wrong dwell angle/gap? Not sure why they should have failed so rapidly in use. What did the points contact faces look like after they had failed? Failing coil will sometimes run from cold for a few miles till it heats up and fails. Leave it to cool down and it may run again for a few more.


'There's no ECU or AMP ................ Maybe that's the problem?' Won't be the problem. Points used in the classic way don't need one. Some of the earlier 'electronic' ignitions such as capacitative discharge used points just to give the timing signal but that wasn't what you're doing. The aldon generates its own signal and is entirely self contained. Just needs a 12v power supply and a 12v 3ohm coil. Simple as.


New plugs, HT Leads, Distributor Cap, Rotor Arm, and coil are nice but probably unnecessary although a new coil won't go amiss just as a check in case the old one was failing. You were pretty sure there was no ballast resistor knocking coil supply voltage down to 9v and have checked the coil supply is indeed 12v? Odd that your starter solenoid has extra LT wiring which would usually be associated with a ballasted coil supply/9v coil and giving a cranking supply to the coil of 12v. Pic below.


What to suggest? Always a problem when you're not confident you have identified the fault. Check the coil and powerspark supplies are good clean ignition live supplies giving 12v. You have the new coil in place. You have fitted a complete set of new ignition components so be confident in them. I can't see there is much else you can do with the ignition.


Tacho wire from the coil? I would leave unconnected for the time being and put some miles on the car. (Still can't really see how the tacho itself can be the problem. But the tacho wiring, yes.).


Electronic components can just reach end of life and fail. Maybe that's what happened to the aldon ignitor. Blowing out points with the wrong coil could explain why that 'fix' didn't work for long. Dunno.


ps. when you do put the tacho back in circuit I would run a new wire from coil neg to it!


Edited by Longboarder

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.