Jump to content

Electrical Issues Following A New Loom Installation


wowblaauw
 Share

Recommended Posts

All, my first post on these here parts - that said, I have found most of the issues with my Zero were answered by the good people on previous posts on the RHOCAR. So here I am a newbie although I've been a member for the past couple of years asking for some good old fashioned help - apologies for the longwinded first post.

 

I purchased a built Zero with many issues from a misfire to electrical problems from a home made loom and as such I wanted (before buying a new kit) test my skills before taking the plunge. So, the loom; I purchased a new GBS P&P loom at the end of last year and fitted while taking out the old home made job - in fact an almost complete strip, a new cooling system, etc and other jobs along the way. So, once the new engine bay and main loom were in these are the faults I came across.

 

First issue bad earths - oops, since rectified and sorted

Second issue, alternator regulator blown - out, repaired and sorted and installed

Third issue, no oil pressure - replaced sender and hey presto

Fourth issue, no water temperature, sender replaced and sorted

Fifth issue, the ECU not switching the ignition circuit - ECU sent to Emerald and...

Sixth issue, misfire on three - ECU sent to Emerald and misfire detected and repaired, no fault found on the switch for the ignition circuit

Seventh issue, failed alternator - again? sent off and repaired

Eight issue, ECU back and no change, sent back - Emerald kindly too a video showing the ECU fully functional

Ninth issue, Alternator failed again, I think, no ignition light on on dash - and the ECU still not switching and a misfire to three and fourth not firing at all - before the alternator failed again I had the engine running post replacing the spark plugs with new, the HT leads with new and the coil pack with new. No change, still missing on three and nothing on four.

 

I guess what I am asking for is some sanity. I have Emerald saying that the ECU is fine

Having replaced just about everything electrical I still have some fundamental issues

GBS say that their looms are fully tested before leaving the factory and therefore cannot be at fault

 

Any advice is good advice, but if someone could lend me a hand here I would be eternally grateful.

 

Thanks in advance, Craig

Link to comment
Share on other sites

Guest lotusPaul

I would say without question that if Emerald say its working then its working. Karl will honestly not let an ECU pass his hands without it being 110%.

Link to comment
Share on other sites

It's not clear what's not working, I'm assuming the ECU doesn't power up and you has a misfire on 3 and and no spark on 4, I agree with Paul, if Emerald say the ECU is OK then that won't be the problem. Based on my experience on fitting an Emerald ECU I'd do the following.

 

Start with the basics first, with the ignition on, the ECU led should turn red and the fuel pump should run for around 5 seconds. When the engine is being cranked, the led should turn green.

 

Make sure the ECU has a decent earth to pin 29, either direct to battery or a decent size ring terminal bolted to something solid.

 

Ignition feed to ECU should be at pins 11 and 28. Check what voltage you're getting here and run a seperate feed direct from the battery if required to see if it makes a difference.

 

Feed to fuel pump comes from pin 20 and is a switched earth. This should be triggering a separate fuel pump relay and personally I'd use an inertia switch as well to cut the fuel pump in the event of a crash.

 

Ignition outputs are pins 25 (driver 1, cylinders 1 and 4) and 5 (driver 2, cylinders 2 and 3). Each ignition output fires a pair of cylinders simultaneously and you seem to have a problem with one cylinder in each pair. How have you verified that there's a misfire on a particular cylinder? Have you tried swapping HT leads in pairs - 1 with 4 and 2 with 3. Does the misfire move to another cylinder?

 

Where does your ignition feed to the coilpack come from, the ignition switch or have you run a separate feed from the battery through an ignition switched relay (best option)

Link to comment
Share on other sites

All, many thanks for your replies - also, please accept my sincerest apologies for my miss post - fit of exasperation and frustration and wasn't watching what I was doing...

 

Ok, engine is a crate engine with 1k miles on it - haven't checked compression yet. The inlet manifold has been checked and reseated just in case with new seals. New plugs, coil pack and HT leads have been fitted. Not much else to say other than I have this issue between the engine, loom and the ECU. Having spent some time with Dave Walker at Emerald we have come to the conclusion that this is a loom issue and as such my next task is to de-instal the loom out of the car and strip the fuse relay box down to check see what is going on with connectivity etc. I was rather hoping someone else had had this issue...

 

Thanks again

 

Craig

Link to comment
Share on other sites

HI Richy, seems you got a post in just before my last response.

 

When I switch on, fuel pumps start, ECU LED goes red and when I crank the ECU goes green as it should. I do have a decent earth (one of my many mistakes), and having rechecked several times am happy with the way the loom has been run. When I asked a local pro to come and help he started at the misfire to number three cylinder worked backwards and found that the ECU was missing on this pot. He also stated that the ECU was not switching. However having sent the ECU off to Emerald they concluded that the ECU was missing on three but there was no fault with switching the ignition feed relay. We did bypass this and earthed the ground pin on the ignition relay which did bring the engine back to life only to misfire on three. I played with this for a bit and sent the ECU back to Emerald who after much coercion on my behalf re-ran all of the tests again only to find that the ECU is good to go. I also put a new map and Emerald informed me that they updated the firmware. I haven't as yet checked the output from pin 11 and 28 - which I will do this weekend ahead of stripping out the loom. If the readings are anything but what is expected then the loom comes out.

 

That said, I now do not have an ignition feed even with the bypass - this is becoming really strange even (I think) my alternator has failed again. If it has it would be the third time the reg has popped - anyone with experience on failing alternators?

 

The ignition feed comes directly from the loom's fuse/relay block and as such and because this is a purpose made loom with no schematic I am rather in the dark with it which is why I think removal and a strip of the fuse relay box is in order. Like I said in my last I was rather hoping someone else had a similar issue which I could work with and circumvent this additional work. However, I am 7 months in with this loom. No pain no gain.

 

Thanks again, the hep is very much appreciated.

 

Craig

Link to comment
Share on other sites

If you are convinced its the loom then Making a new loom is not hard, a little time consuming perhaps. I wired my canems ecu from scratch, much as it seems complicated it isn't. I.m sure emerald can supply a wiring diagram. Just follow it one wire at a time and have one decent point for all engine loom earths. Took me a good few days but it worked 1st time no issue and is way cheaper and better quailty than any bought loom.

Link to comment
Share on other sites

on fitting of my megasquirt all earths are to engine block nothing is earthed on chassis this reduces noise feedback which can cause the ecu to go a bit funny apparently

Edited by tractor
Link to comment
Share on other sites

After spending nigh on £900 on the factory loom (engine and chassis) - its predecessor was a bit of a birds nest so in my constant search for perfection I went the way of the GBS P&P loom - I am reluctant to throw it out and start again. That said, I wired the dash from scratch which was simple enough - just a case of following the routes. I have dash switches rather than stalks. I don't have an issue with electrical work per se but this loom is an absolute nightmare. I have no schematic and to be honest I was hoping that someone else may have had the same experience and was willing to share not that I would want this on anyone else...

 

The loom is definitely coming back out tomorrow and will be on the bench ready for my meter. I am determined to find out why this loom is functioning the way it is and my wish is to make others aware that this may be the case despite what GBS say. Anyhow, I'll get back to you when I have this apart with a level of understanding so I can share it.

 

Cheers, Craig

Link to comment
Share on other sites

Update, the issue is with the block to ecu connector with the engine loom. One problem solved by bending pin 4 on ecu to make better contact with connector. Did try closing the connector female pins but couldn't make the connection reliable. My only worry here is one of reliability. Anyhow one problem solved leaving the misfire.

 

I have a misfire on cylinders 3 and 4. I removed the manifold cleaned all surfaces and fitted new jenvey O rings. No change. I've replaced the ht leads, coil pack and plugs - no change. I had a spare set of injectors kicking around so changed these but without change. Any ideas would be gratefully received. The map I'm using was supplied by GBS and was running successfully before I changed the looms.

 

Thanks, craig

Link to comment
Share on other sites

Eureka! I was measuring outputs from the ecu to injectors and then matched to the map driving the ecu and here's what I found

 

Cyclinder 1 injector - correct

Cylinder 2 injector is cyclinder 4

Cylinder 3 injector is cylinder 2

Cylinder 4 injector is cylinder 3

 

My next question is this; any ideas on how to change the injector sequence in the ecu - why because my engine loom now resembles something of Heath Robinson affair.

 

Thanks again in advance

 

Craig

Link to comment
Share on other sites

Have you downloaded the emerald instructions?

There should only be two connections from the ECU into the main loom of the car and that is a 12v+ through the ignition switch and starter relay if you have one fitted and a permanent 12v+ supply so that the ECU can do some 'housekeeping' as emerald put it after the ignition is off.

All the rest of the ecu connections are via the emerald ecu/engine loom. Do you have this or is the loom something that GBS sell that is a full chassis and engine loom?

The emerald can only run sequential injection if you have a cam phase sensor fitted, otherwise you need to be set for batched injection.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...