Jump to content
deano266

Superspec fuel pump

Recommended Posts

Hi guys. 

Recently my Superspec has developed an interesting quirk. Some days the fuel pump will activate on the key like a good car should. However some days it won't prime unless I attach the fuel pump wore to a live wire momentarily to fire the pump up and then it will run no problem.

 

Does anyone have idea what could cause this. I have swapped the relay for the ECU one and same result 

Share this post


Link to post
Share on other sites

Try running a new wire from ignition to pump? , sticky pump?

Does sound a weird one though

Share this post


Link to post
Share on other sites

How is the pump relay controlled? (You need to know this so you can track all components and wiring that control the pump to locate the fault.) Most ECU equipped cars have the ECU switching the fuel pump relay. Some cars might have the fuel pump relay directly switched by 'ignition on' but would need to have a safety cut-off (oil pressure or impact relay are common) in case of crash.

Share this post


Link to post
Share on other sites

The super-spec fuel pump is controlled by the ECU.  It primes for a few seconds when ignition switched on, then turns off (if you haven't started engine).  Then runs continuously when engine running.  Connect a 12v light bulb across fuel-pump - will show whether it is faulty pump or the 12v to it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...