Jump to content

Bodged wireing now car won’t start


Keith Cooper
 Share

Recommended Posts

Hi guys,   Eureka ..... the 2nd hand clocks I ordered from eBay arrived so I took out the clocks ( which was a 2 hour nightmare) and swapped them over and the car started straight away...... I looked at the clocks in more detail and sure enough you can see where the circuit board behind has burnt out.... I have attached a picture (the break is next to the ford sticker).

thankfully I was able to swap over all the clocks from the broken circuit board set and put them in the one that works so I have my original mileage back :)...

thanks for all you support guys it was quite a few stressful days trying to work this out but at least I have learnt a lot of things about my car.... also the coil and fuel pump getting its power from my clocks..... who knew !!!!!

i just need to secure the multi plugs in the back of the clocks a bit better than the person that installed them previously 

I also modified the clutch at the pedal end as per your suggestions and I have changed the short clutch cable that someone put in the car and the clutch is 100 times better.... :)    so getting there :) 

9DC90DAC-2EC3-4BE6-9EDD-0FA758D0EDD9.jpeg

BF84B0EB-E8C3-4527-ACBD-D3ADC53F9983.jpeg

F7A45649-060E-4217-9D22-0CE8D39B4A68.jpeg

Link to comment
Share on other sites

  • Replies 34
  • Created
  • Last Reply

Top Posters In This Topic

If the multiplug can be put in the wrong way around, it might be worth marking both parts on the same side with paint or a permanent marker so it's more obvious which way around it goes.

Link to comment
Share on other sites

Yes agreed,  it’s because the multiplugs used in the back of the instrument clocks are not the correct ones for the clocks...

it should be 2 X 12 pin multi plug that are sided so that they can only go in one way, what I actually have is 4 X 6 pin plugs that fit in any way.... so yes I will mark them in such a way that it can never be put in wrong again.... ideally I will try and find some original Ford multiplugs for the instrument clocks and re-wire them .... anyway I am certainly a lot more wiser with regards my RH.......

BEST regards 

Link to comment
Share on other sites

15 hours ago, Keith Cooper said:

Yes agreed,  it’s because the multiplugs used in the back of the instrument clocks are not the correct ones for the clocks...

it should be 2 X 12 pin multi plug that are sided so that they can only go in one way, what I actually have is 4 X 6 pin plugs that fit in any way.... so yes I will mark them in such a way that it can never be put in wrong again.... ideally I will try and find some original Ford multiplugs for the instrument clocks and re-wire them .... anyway I am certainly a lot more wiser with regards my RH.......

BEST regards 

I have the correct plugs I think if you want them, I redesigned my dash over the winter so if I can find them there yours!!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...