Jump to content

Recommended Posts

Hi Guys

Yes it's me again, the annoying bloke with lots of questions!

 I Picked my car up last week and before I drove it home I checked the oil level. Bang on maximum. However at low revs the oil light would flicker. I put this down to the oil being stood for 3 years while car was not being used. Today I decided to change the oil and filter. A quick google revealed the 2.0 Pinto engine should have around 3.8 litres of oil inc filter? firstly is this correct? secondly I drained about 2.6 litres out the engine. I have now put in 3.8 litres but the level is about twice as far as the maximum line on the dipstick. So my assumption is the car may have the wrong dipstick? I have attached photos of the dipstick and sump in case anyone can offer me some advice.

 

Thanks in advance

 

Ray

2020-09-01_17_53_03.jpg

2020-09-01_17_53_10.jpg

2020-09-01_17_53_13.jpg

2020-09-01_17_53_29.jpg

Edited by raystevenson
Link to comment
Share on other sites

1 minute ago, maca said:

Looks like a Pinto so use 20/50 oil the old school type.

 

I used to use this from Halfords https://www.halfords.com/motoring/engine-oils-and-fluids/engine-oil/halfords-classic-oil-20w50-5l-537977.html

 

Edited by MarkBzero
Typo
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...