Jump to content


RHOCaR End of Season Bash 

Come and join us for our Annual event  on 14th to 16th September

Camping, Family Fun,  Evening Entertainment and like-minded Company

 

Full Details and entry form here:

http://www.rhocar.org/index.php?showtopic=46637


 


Photo
- - - - -

Relays


  • Please log in to reply
12 replies to this topic

#1 nelmo

nelmo

    Magazine Editor

  • Committee
  • 771 posts
  • Location:Surrey
  • Car type:GBS Zero

Posted 12 February 2018 - 09:07 AM

I'm no expert on relays but my indicator flasher relay seems to have died this morning - my indicator dash light comes on but does not flash and the relay is making a buzzing noise.

 

Sounds terminal to me but are relays affected by cold? It was just about freezing this morning - is it possibly going to start working when the temperature rises?

 



#2 jaimo

jaimo

    Wheely good builder!

  • RHOCaR 18
  • 1,699 posts
  • Location:south yorkshire / doncaster
  • Car type:robin hood exmo

Posted 12 February 2018 - 09:57 AM

Sometimes relay stick give them a tap
Will it ever be a good runner ?

#3 nelmo

nelmo

    Magazine Editor

  • Committee
  • 771 posts
  • Location:Surrey
  • Car type:GBS Zero

Posted 12 February 2018 - 10:00 AM

I was wondering about that but aren't all modern relays solid-state? Mine are only a couple of years old...



#4 theduck

theduck

    Chairman

  • Admin
  • 3,587 posts
  • Location:Birmingham
  • Car type:Sierra S7

Posted 12 February 2018 - 10:26 AM

I was wondering about that but aren't all modern relays solid-state? Mine are only a couple of years old...


Nope, most automotive relays are good old fashioned proper mechanical ones.

#5 florin metal works

florin metal works

    Hants & Dorset Area Secretary

  • Area Secretary
  • PipPipPipPipPip
  • 7,749 posts
  • Location:Salisbury
  • Car type:2B+

Posted 12 February 2018 - 10:42 AM

Was the battery good enough to start the car?  If so check the earthing/power feed to the relay.  As above a continuous buzz from a relay indicates its not got sufficient current to close the circuit, don't leave it buzzing as the relay coil draws more current when the magnetic circuit is in-complete. 



#6 nelmo

nelmo

    Magazine Editor

  • Committee
  • 771 posts
  • Location:Surrey
  • Car type:GBS Zero

Posted 12 February 2018 - 11:40 AM

Hmmm, could it be a problem if it is on too long?

 

I don't have column stalks, my indicator is a manual switch on my dash (no auto-cancelling). On my way to work this morning, after one turn, I forgot to switch the indicator off for about 2 miles (yeah, I know, one of those people  :sorry: ) and it was after that I noticed it wasn't flashing (I can't be sure if it was before - I think it was).

 

I'll try give it a whack later, although it's not easy to get to...



#7 Nige2e

Nige2e

    Wheely good builder!

  • RHOCaR 18
  • 163 posts
  • Location:Leighton Buzzard
  • Car type:2B+ 1.8 CVH IVA & Registered Nov 2013

Posted 12 February 2018 - 01:14 PM

Do the indicators actually come on? Depending on the electro-mechanical workings of the indicator circuit, it could just be one of the bulbs has blown and so does not have enough energy to energise the relay. Or you may have a short somewhere.

 

Nige



#8 nelmo

nelmo

    Magazine Editor

  • Committee
  • 771 posts
  • Location:Surrey
  • Car type:GBS Zero

Posted 12 February 2018 - 02:29 PM

Ahh, hadn't actually checked that - I was working on the belief that this would cause the indicators to flash even faster, which is what happens on a normal car but I'll check - thanks...



#9 nelmo

nelmo

    Magazine Editor

  • Committee
  • 771 posts
  • Location:Surrey
  • Car type:GBS Zero

Posted 13 February 2018 - 09:06 PM

So, I'm guessing a relay that rattles like a castanet is kaput, yeah?

And coincidentally, it's a Cargo relay (surely the most ironic product name ever), same as my alternator that died a few weeks ago. Guess which manufacturer I'll be avoiding for, like, forever?!

#10 nelmo

nelmo

    Magazine Editor

  • Committee
  • 771 posts
  • Location:Surrey
  • Car type:GBS Zero

Posted 13 February 2018 - 09:50 PM

Is it a relay or the flasher thats buzzing gone?.

It's just one unit, isn't it? This is a pic of the inside - you can see the capacitor has dropped off which was the rattle:

smallrelay.jpg

Edited by nelmo, 13 February 2018 - 09:50 PM.


#11 florin metal works

florin metal works

    Hants & Dorset Area Secretary

  • Area Secretary
  • PipPipPipPipPip
  • 7,749 posts
  • Location:Salisbury
  • Car type:2B+

Posted 13 February 2018 - 11:09 PM

The capacitor is probably in circuit to damp the spark across the main contacts --- without it being in its correct place ( electrical place -- the contacts are probably burnt & causing a high resistance & no glow of lamps,  Its a very unusual fault though, all the relays in our car are from the donor.



#12 Nige2e

Nige2e

    Wheely good builder!

  • RHOCaR 18
  • 163 posts
  • Location:Leighton Buzzard
  • Car type:2B+ 1.8 CVH IVA & Registered Nov 2013

Posted 15 February 2018 - 01:02 PM

That's more likely to be the timing capacitor. They don't usually use electrolytic capacitors to supress sparks.

There is a white stripe down one side of the capacitor, that's the negative side, if you are soldering it back in.

 

Nige



#13 nelmo

nelmo

    Magazine Editor

  • Committee
  • 771 posts
  • Location:Surrey
  • Car type:GBS Zero

Posted 15 February 2018 - 04:08 PM

Thanks for that but, apart from the fact that my soldering skills are sorely lacking, I had to cut the unit open to get to the inside for that pic.

 

Also, there has been some  arcing going on because the side of the relay unit shows signs of melting, probably when I was running it after the capacitor dropped off.

 

Bottom line - it is one very dead relay/flasher unit  =@  - new one on order...