Jump to content
Sign in to follow this  
nelmo

TPS setup in Emerald

Recommended Posts

My throttle pedal is not able to open the throttle body (standard Ford part, GBS plenum, Zetec) all the way, due to the way I adapted the throttle cable originally. Never been a problem but I replaced the TPS and I needed to recalibrate the new one in the Emerald software.

My question is, should I calibrate by manually turning the throttle body by hand (which will give a wider range) or use the throttle pedal with the shorter range?

I've done it using the pedal and the car does feel a little bit jerkier and there seems to be a few more pops from the exhaust but I could be imagining it...

Share this post


Link to post
Share on other sites

using the pedal gives you the true measurement TPS signal zero at rest and throttle fully deprest 100 percent as far as i know doing it at the butterfly will give you a false reading if using the pedal it is not opening it fully 

i would get your cable working properly to open it full 

i got a focus throttle cable which works perfectly 

Share this post


Link to post
Share on other sites

Do it the same as how the previous TPS was set up prior to your engine being mapped. So if the previous TPS was calibrated by pedal, do the same now. That will keep your map consistent.

Share this post


Link to post
Share on other sites

ah yes, that's a good call...thanks... 🙂

Share this post


Link to post
Share on other sites

Agree to all the above for current recalibration.

Are you saying the pedal only partialy opens the throttle butterfly? If so then you have extra performance potentialy available. Slight lengthening of the pedal arm to give more cable movement or reduction in length/diameter of the throttlebody arm to require less cable movement, each giving full butterfly opening could be a good plan. However changes to the emerald  map would then be needed as top end airflow would be greater than currently. But free extra power? Whats not to like?

Share this post


Link to post
Share on other sites

Why is you throttle not giving full movement, it should, the standard set  certainly should, so that could do with fixing.

You must set it O% to full throttle, particularly if you are using the maps from GBS.

You will also need to calibrate the map to the throttle, or they will be out throughout the map.

I have a procedure somewhere if you need it, or I can team viewer in, can usually get it about right

If you don't the map will be out, even if the TPS is calibrated

Simon

Share this post


Link to post
Share on other sites

The throttle cable from GBS has a plastic section on the end which has to be trimmed - I obviously didn't take enough off. With the TPS calibrated to the butterfly, pushing the pedal as far as the cable will allow only opens the butterfly 77%, according to the Emerald software. I guess 100% would be nice but since I can happily spin the wheels in the first 3 gears, I'm not too bothered 🙂

Does the map matter much if I have a wideband lambda? I thought the ECU based everything off that? 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...