Jump to content

Pinto compression test issues


Recommended Posts

So I started doing a compression test on my 2l pinto. I noticed that cylinder 2 was slightly down on compression and on advice dropped a little oil in and sure enough the pressure reading increased. 
 

It’s not starting comfortably now although just about got there in the end. Dumb question, would that be because of the oil in the cylinder? Is that a good or bad thing to do? 

Link to post
Share on other sites

Putting a bit of oil down the bores confirms it’s a ring problem 

but putting oil down the bores can fowl the plugs 

I would use a different set of plugs for the test or after it. 
 

Link to post
Share on other sites
21 minutes ago, blue said:

Putting a bit of oil down the bores confirms it’s a ring problem 

but putting oil down the bores can fowl the plugs 

I would use a different set of plugs for the test or after it. 
 

That sounds likely not sure why I thought putting oil where the plugs go wouldn’t be a problem. Lol. I think I’ll try just to keep it running long enough to get up to temperature to do another test then change the plugs. I don’t think it was massively under anyway - around 130 cold and only marginally down on cylinder 2. 

Link to post
Share on other sites

I cleaned off the plugs and now it starts much better. 
 

oddly the compression readings were slightly lower on a hot engine.  
 

at just over 126. I was expecting higher. 
 

is that reading for concern or if all 4 are roughly the same then it’s ok? 

Link to post
Share on other sites

as long as all four are roughly the same then its ok and i wouldnt worry about a lower comp rate with warm engine your oil will be thinner 

why are you doing a comp test  

Edited by tractor
Link to post
Share on other sites

Thanks. Just trying to eliminate a few things.  It’s been lumpy for a bit and thought I’d start with the basics and get some confidence there’s nothing dramatically wrong inside. 
 

Comp test dime

timing set to about 8 degrees

weber 3236 dgv unusual behaviour though. I’m getting back fire on sharp acceleration through the exhaust and without the filter on I can see it in the carb. Sounds like unburnt fuel? The plugs are typically very dirty with soot and carbon build up despite being newish plugs. 
 

my guess is the mixture is too rich? 
 

I’ve tried winding in the idle screw as far as it’ll go but it doesn’t seem to make any difference to the running. 
 

I put a Gunsen colour tune plug in to have a rough look. Idle is burning yellow but on acceleration it goes a nice blue. This gives me an increased confidence it is definitely rich at idle. 
 

ive tried changing the idle jet to a smaller 45 but still doesn’t make any difference (and it did before). 
 

the comp test was to just give me confidence that I wasn’t leaking oil into the cylinder which could cause the dirty plugs. 
 

woukd you agree that the issue is with the carb?

it’s a fairly new carb but I have heard of issues with the float adjustment which can cause too much fuel to be pulled through  

 

any other suggestions? 

Link to post
Share on other sites

So I went a bit further this evening. Took the carb apart. 
checked the float level etc no apparent issue. 
 

put it all back together. 
 

I did notice though when setting it all back up I had trouble keeping the engine running unless the idle screw was turned in fairly considerably. That worried me slightly because surely that means when it’s idling, it’s not actually running on the idle jet and maybe the main Venturi has opening slightly. Which could explain why the idle screw has no effect.  
 

I changed the idle jet completely so fairly confident it’s not that. 
 

could it be the something else blocked? 
 

im not sure if I should move this to a different thread now it’s nothing to do with compression... 

Link to post
Share on other sites
9 minutes ago, IanS said:

Is not the idle adjustment an air bypass, screw in to go rich, screw out to go weak.

I should have been more explicit. 
the idle speed screw needs to be turned in causing the engine to Rev harder in order for it it idle. This must be moving it off the idle circuit. 
 

adjusting the idle mixture no longer makes any difference. The spark now always appears rich when idling. I’m assuming this is because it is no longer on the idle circuit completely. Could be something else though. 

Link to post
Share on other sites
5 hours ago, Snapperpaul said:

What air filter are you using?

it may actually be running lean if air flow is greater than stock or running rich if you have one of those chrome/wire things that are ½” thick

It’s the saucepan type one. However, whilst it’s in the garage I don’t have the air filter on and it’s still running rich at idle. However, I pulled the carb off last night and I can see that where the idle stop is set, the progression ports are exposed which may explain why the idle mixture screw has no affect. 
 

the problem if I wind out the idle screw it won’t run on just the idle jet.   I’ve had the jet out abs it seem clear and swapped it up or down a size. 
 

im starting to think that it’s narrowing down the the problem and causes. 
 

problem - engine won’t run just on idle circuit. 
why?

fuel not flowing through idle circuit - vacuum leak below the throttle plate? Possible but sprayed carb cleaning when running with no affect 

low fuel pressure? Possible, but the bowl is fed ok and enough to power other circuits. 
 

float is set to the wrong position and transitions too quick off idle circuit? Maybe - I had a quick look at the float and have a metal rule coming today to measure it up. Not too confident here but I’ll give it a go. 
 

idke circuit is blocked? Maybe - I’ll pull out the needle and jet and try to spray carb cleaner through.  Any tips welcome to prove it’s clear. 
 

any other tips? 

Link to post
Share on other sites

Completely pulled the carb apart today. Adjusted the float to perfect spec. 
 

put it all back together - still no good. I just can’t get it to run on idle only. As soon as i wind out that idle screw it dies. I can only get it to run with idle screw in about 8 times which I believe is way past idle and into the progression ports. 
 

stuck. Out of ideas. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...